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What is ProtoLab?
ProtoLab is a low cost, easy-to-use analog (AC/DC) circuit

design and simulation tool. It allows the user to create and

edit analog circuits instantly on a PC while choosing from a

complete list of active and passive components including:

•  NPN & PNP Transistors

•  Diode

•  Zenor Diodes

•  Capacitors

•  n-channel MOSFET

•  Resistors

•  Inductors

•  Voltage Sources

•  Current Sources

•  Jumper wires

ProtoLab also allows the user to analyze circuits using

built-in virtual test instruments. Instruments include:

•  Oscilloscope

•  Ohmmeter

•  Voltmeter

•  Ammeter

•  Wattmeter

Installation Procedure
Windows® 95 and above:

Click Start on the taskbar, choose Run, then type a:setup

System Requirements
IBM PC-386, 4MB RAM, SVGA graphics, Windows® 95 or

higher

If you have any difficulty installing ProtoLab 4.0, contact:

Toll free in USA & Canada: 1-800-572-1028

email: info@globalspecialties.com

FAX: 714-921-6422

GLOBAL SPECIALTIES®

Customer Service Dept.

22820 Savi Ranch Pkwy, Yorba Linda, CA 92887

Registering ProtoLab:
You may register your ProtoLab software online by visiting: 

http://www.globalspecialties.com/register.html

ProtoLab Operation
Upon start-up, ProtoLab's screen will be ready for a new
circuit lay-out. To load pre-designed circuits included with
ProtoLab, or to load pre-existing circuits from memory,
perform the following:

Loading Pre-designed circuits or Saved circuits
1. Under the File menu select "Load."
2. This will take you to the ProtoLab folder, or directory.
3. Select the desired circuit with the mouse, then left-click "OK."

To close a circuit and start a new circuit
1. Under the File menu select "Save As."
2. Under "File Name" enter the desired name of the circuit.
3. Select "OK."
4. Under the File menu select "New."
5. The design palette will now be blank and ready for circuit

lay-out.

ProtoLab's Pre-designed Circuit Listing:

FILE NAME DESCRIPTION
Amp_bip.wpf Single transistor AC coupled amplifier
Amp Jeed.wpf Single transistor AC coupled amplifier w/ DC feedback
Bdiod.wpf Full wave bridge circuit - widely used in a power supply
Bridge_r.wpf Wheatstone bridge
col2.wpf Transistor Colpitts Oscillator, sine wave osc. for A.F. or R.F.
gmos.wpf MOSFET phase shift oscillator, inductorless osc. for A.F.
i_mirr.wpf Current mirror circuit
int_diff.wpf Collection of passive integrators and differentiators
mlt_mos.wpf MOSFET multivibrator - square wave oscillator
mltl.wpf Transistor multivibrator
Monost.wpf Transistor Monostable or one-shot
Mos_amp.wpf Single MOSFET amplifier
osc.wpf Two Transistor LC oscillator
res1 .wpf R.F. Tuned Collector Transistor Amplifier
resonan.wpf Passive series and parallel LC tuned circuits
stab.wpf Zener diode stabilized power supply
stab_i_1.wpf Current stabilizer

tsh.amp Schmitt trigger
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The ProtoLab Toolbar
All of ProtoLab's functions are performed from the main

toolbar. Before getting started, please familiarize yourself

with the toolbar illustrated below:

Component Placement
ProtoLab's graphical interface is extremely user-friendly. 

To place a component on the design palette, perform the

following: Select any one of the following from the main

toolbar:

Select the desired component with the mouse and click on it

with the left mouse button. At this time, a menu will open on

the left-hand side of the design palette. Choose the desired

component from this menu and place it in the desired location

on the design palette. With ProtoLab, there is no need to keep

the mouse button pressed, the component will automatically

be present on the mouse pointer until it is placed on the palette,

and until another design element is chosen. This allows the

user to place the component multiple times without going back

to the placement menu.

The ProtoLab® manual, software, and documentation are

copyrighted, and all rights are reserved. This product, including

software and documentation, may not, in whole or in part, be

copied, photocopied, translated or reduced to any electronic or

machine-readable form without prior written consent, except

for copies retained by the purchaser for backup purposes.

No warranty or representation, either expressed or implied, is

made with respect to ProtoLab®, its quality, performance,

merchantability, or fitness for a particular purpose. As a result,

this product is licensed "as is", and you, the licensee, are

assuming the entire risk as to its quality and performance.

Global Specialties® reserves the right to revise this operation

manual, and all accompanying software and documentation,

and to make changes in the content without obligation to

notify any person or organization of the revision or change.

In no event will Global Specialties® be liable for direct, indirect,

special, incidental, or consequential damages arising out of

the use or inability to use this product or documentation, even

if advised of the possibility of such damages. In particular,

Global Specialties® shall not have liability for any hardware,

software, or data stored or used with the product, including

the costs of repairing, replacing, or recovering such hardware,

software, or data.

Windows® and the Windows Logo are U.S. Registered

Trademarks of Microsoft Corporation.
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Rotating a component
The orientation of components may be changed by selecting

the       button. To do this, perform the following:

1. Select a component from the toolbar.

2. Once the element is selected, select the       button from the

main toolbar to rotate the component to the desired orientation.

3. Place the element on the design palette.

Mirroring a component
Active components may be either "rotated" or "mirrored."

To rotate an active component, follow the previous proce-

dure. Mirroring allows the user to immediately access the

complement of the previously placed component without

rotating. To mirror a component, perform the following:

1. Select any active component                 from the main toolbar.

2. Select the desired component (npn transistor, pnp transistor,

or n-channel MOSFET) from the toolbar on the left side of

the design palette.

3. Once the element is selected, select the      button from

the main toolbar to mirror the component.

Setting / Changing Component Parameters
Once a component has been placed into the circuit, its

value can be set or changed by performing the following:

1. Click on the desired component with the RIGHT mouse

button. This will open the "Component Parameter" window.

2. Enter the desired component values

3. Select "show values" to display the values on the circuit.

4. Select "OK."

Selecting Wires / Junctions
Grounds
The ground symbol is not an actual connection to ground

and should only be used in the circuit to represent a ground

connection. All grounds in the circuit must be connected

together in order for the circuit to work properly.

Wires
To connect components to one another, select the

"Junction" button from the upper toolbar. At this time a

menu will open at the left side of the design palette. From

this menu, wires, junctions and grounds may be selected.

When the wire is selected the mouse pointer will have a "1"

attached. This is the beginning of the wire link and should be

placed on an element's output. Once the "1" has been

placed, the mouse pointer will now have a "2" attached. The

"2" signifies the end of the connection and should be placed

at the input to the next element. While the "2" is displayed,

right angle runs may be placed by clicking the right mouse

button until the desired node is reached.

Junctions
Junctions may be placed at any grid line. Junctions prove useful

where wires cross, and are used to signify an interconnection.

Deleting a Component
To delete a component, select the      button from the main

toolbar. Once this button is selected, simply "click" the left

mouse button on the desired element to remove it from the

circuit.

Moving the Circuit
The circuit may be moved about the design palette by

selecting the      button from the main toolbar. Once selected,

a hand will now be displayed instead of the mouse pointer.

To move the circuit, place the hand onto any part of the circuit

and drag the mouse while the right mouse button is engaged.

Turning the Power ON and OFF
1. Turn Power "ON" by selecting the "ON" button located

at the top of the toolbar.

2. Turn Power "OFF" by selecting the "OFF" button located

at the top of the toolbar.

Testing a Circuit
Now that a circuit has been designed, it may be tested.

ProtoLab has five virtual instruments that may be selected

for circuit testing.
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2. Place the "ground" probe at potential ground of your circuit.

3. Select the "1" or "2" probe depending on the desired

viewing channel.

4. Select the appropriate display channel according to the

desired reading by using the mouse to select either

Channel "1&2" at the "Display section, located at the

bottom left corner of the O-scope.

5. Turn power on. 

6. Close the O-scope by selecting the ("CLOSE") button in

the top left corner of the oscilloscope screen.

Voltmeter Operation
To operate the voltmeter, power to the circuit must be on.

To use the voltmeter, observe the following instructions:

1. Select the      button from the main toolbar.

2. At this time the voltmeter window will open to the left of

the design palette.

3. Select the "ground" probe by selecting the          minus

button directly on the voltmeter and place it at ground

potential of the circuit.

4. Select the "positive" probe by selecting the positive

button          located on the voltmeter.

5. Turn Power on to the circuit.

6. The meter should now display the proper reading.

Oscilloscope Operation
To utilize the oscilloscope, select the      button from the

toolbar. The Oscilloscope window will open to the left of

the design palette.

Oscilloscope Settings
ProtoLab's oscilloscope works like any other bench-top

oscilloscope. Before taking measurements, the Volts/Division

and Time/Division controls must be set to accurately and

comfortably monitor the circuit's performance.

Adjust the Volts/Division control for the desired channel by

using the UP/DOWN buttons, which are located below the

oscilloscope's display. 

Adjust the Time/Division control by using the UP/DOWN

buttons, located at the bottom of the oscilloscope.

Probe Placement
Now that the oscilloscope is set to the desired levels, it is time

to place the probes. ProtoLab's oscilloscope is dual channel,

therefore 2 channels may be monitored simultaneously. To

place the oscilloscope probes, perform the following:

1. Select the desired probe from the lower right corner of

the O-scope      . The "0" probe is for the "ground" probe.

The "1" and "2" probes are for channel 1 and 2 respectively.
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Ammeter Operation
Using the ammeter does not require you to open the cir-

cuit for a reading. ProtoLab automatically does it for you.

To operate the ammeter, observe the following:

1. Select the       button from the main toolbar.

2. Select the              button on the meter.

3. Click the left mouse button between the desired ele-

ments to measure the current. ProtoLab will automatically

break the circuit and insert the ammeter where the meas-

urement is to take place.

4. Left-click anywhere on the circuit to move the meter.

5. Turn the power to the circuit on.

Wattmeter Operation
To measure the wattage of a component observe the fol-

lowing:

1. Select the      button form the main toolbar.

2. Turn power to the circuit on.

3. Left-click the mouse pointer on any element to read its

wattage.

Ohmmeter Operation
In order to perform measurements using the Ohmmeter,

power to the circuit must be off.

1. Turn power off.

2. Select the      button from the main toolbar.

3. Select the negative lead          and place it at ground

potential by left clicking the mouse pointer.

4. Select the positive lead          and place it across the

component or area that is to be measured.

Displaying the Design Palette Grid
The design palette grid may be displayed by selecting the 

on the main toolbar, or by using the "Options" menu.

Under the Options menu, select "Grid." This will turn the

grid on or off.

Using the "Zoom" Feature
The zoom feature allows the user to see a larger or

smaller area of the design palette. The zoom feature can

either be used by selecting the             buttons or by using

the "Options" menu. Under the Options menu, select

"Zoom," then select either "large" or "small."

Using the "Precision" feature
The precision feature allows the user to adjust timing intervals

and voltage and current steps for precise analysis. Precision

settings are preset to optimum operating levels for circuits of

moderate size. As circuits become large, it may be necessary

to change the "precision" settings to make the analysis run

faster. To change the "precision" settings, perform the following:

Under the Options menu select "Precision." This will open

the "Precision" menu. Change the setting according to the

maximum desired operating efficiency by either selecting

or deselecting the boxes marked "Steady State Analysis",

"Disable Small Time Steps", and "Advanced Time Analysis".
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Circuit response time may also be enhanced by increasing

or decreasing the levels of V0, Va, l0 and la. Increasing

these levels will enable the simulation to occur more quickly,

but may reduce precision. Decreasing these levels will slow

down the simulation, and will allow for greater accuracy.

Printing a Circuit
Circuit designs may be printed by selecting the       button

from the main toolbar. Printing may also be achieved by

selecting "Print" under the file menu. ProtoLab uses the

printer setting already established under the Windows®

operating system.

Using ProtoLab's On-line Help
ProtoLab has on-line help which is constantly displayed at

the bottom of the screen just above the Windows® "START"

bar. During each operation, the help bar will instruct the

user on how to successfully complete each task.
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